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1.Herb has some data to display in a form, and he would like to have it display in a formatted grid. What 

option would he use to format this data layout?  

A.Create > Table  

B.Create > Layer  

C.Create > Section > Table  

D.Create > Layout Region > Table  

Answer:A  

2.Lynne created a Book Review application that has a default access level of Author. She created a 

Review document, but was unable to edit the document later. Why would this problem occur?  

A.The document form design does not include a Readers type field.  

B.The document form design does not include an Authors type field.  

C.Her ACL entry needs to have the Edit document option selected.  

D.She needs at least Author access with the Create Documents option selected.  

Answer:B  

3.Peter is working on the Sales Discussions application. He is building a new view that should display all 

main documents, and also all documents that have been submitted in response to the main documents or 

in response to other comments. Peter is trying to determine which @Function refers to all Response and 

Response to Response documents of parent documents. Which formula meets Peters needs?  

A.@Responses  

B.@AllChildren  

C.@AllResponses  

D.@AllDescendants  

Answer:D  

4.Norma has a form action that allows users to create comments for the existing document. When Norma 

views the form in her Web browser she sees the action, but when she opens the form in her Notes client, 

the action is not visible. Which one of the following should she do to correct the problem?  

A.Make sure the comments form has a default access for all readers and above.  

B.Make the action a shared action and disable the Hide-when settings for Web browsers.  

C.Check that the Web Access property for the action bar is not set to Display Using Java Applet.  

D.Check the action Hide-when settings to make sure that the action is available for Notes 4.6 or later.  

Answer:D  

5.Which one of the following accurately describes field names?  

A.They must be unique in a database.  

B.They must include text and a number.  

C.They can only be used once in a view.  

D.They can only be used once on each form.  

Answer:D  

6.Victor has a field that allows the user to enter the list price of a video. What type of field makes sure that 

the value of that field is numeric?  

A.Number  

B.Dollar  

C.Currency  

D.Text field with @TextToCurrency Input Validation formula  

Answer:A  
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7.Judy has created a private agent to update the Readers fields in the Video Rental application. She 

wants to allow Jason to use the same agent. How can she do this task?  

A.Change the agent property from private to shared.  

B.Copy the agent from her workstation to a Domino server.  

C.Add Jason's fully canonical name to the agent's Readers list.  

D.Delete the agent. She must create it again as a shared agent.  

Answer:A  

8.When Eduardo tried to save a document, he got the following error message: Incorrect data type for 

operator or @Function: Text Expected. Which one of the following did he most likely do to cause this error 

to happen?  

A.He entered text in a number field.  

B.He neglected to place a formula in a validation event.  

C.He neglected to place a formula in a translation event.  

D.He combined a text field and a time field in a formula.  

Answer:D  

9.Roberto has been asked to modify the Membership view in the Video Rental application. A green check 

mark should display in the Approved view column for each document where membership has been 

approved. He set the view column property to Display values as icons, and now he needs to write a 

column formula. What is the column formula he needs to use?  

A.@If(Approved = "Yes"; 82; 0)  

B.@If(Approved = "Yes"; @OpenImageResource("checkmark.gif"); "")  

C.@If(Approved = "Yes"; @Icon(82); @Icon(0))  

D.@If(Approved = "Yes"; @Column(82); @Column(0))  

Answer:A  

10.Robert does not want Authors in the Video database's ACL to be able to edit certain fields in 

documents that they created. Which one of the following can he do to accomplish this task?  

A.Set field security options to Must have at least Editor access to use.  

B.Use a Readers field on the form to prevent access to existing documents.  

C.Use an Authors field on the form to prevent access to existing documents.  

D.Create a standard section on the form and put the restricted fields in the section.  

Answer:A  

11.Tony would like to make it easier for users of the Video application to enter new documents using the 

Video form. He'd like users to be able to create new Video documents while in a view. Which one of the 

following should Tony do to build this interface?  

A.Create a view action that has the following formula: @Command([Create]; "Video").  

B.Create a form action that has the following formula: @Command([Compose]; "Video").  

C.Create a view action that has the following formula: @Command([Compose]; "Video").  

D.Create a database action that has the following formula: @Command([Create]; "Video").  

Answer:C  

12.Stacee has been asked to add a feature to the Video Rental application. Users should be able to drag 

videos into a Favorites area for future access. What design feature would allow Stacee to add this 

functionality?  

A.Views  

B.Agents  
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C.Folders  

D.Custom user views  

Answer:C  

13.Mickey wants to allow soft deletions in his database. How does he enable this action?  

A.By selecting the Advanced Database property, Allow soft deletions.  

B.By selecting the Form property Allow soft deletions, for all forms that should have this property.  

C.He doesn't need to do anything. All databases on a Domino server have soft deletions enabled 

automatically.  

D.By adding a field called $SoftDelete, with a computed value of "1", to all documents that should have 

soft deletions enabled.  

Answer:A  

14.Yuki wants to add a field to her form that allows multiple values to be selected or cleared by clicking 

next to the item. What type of field should she use?  

A.Text  

B.Checkbox  

C.Combobox  

D.Radio Button  

Answer:B  

15.Rita has built an agent that changes documents with an Approved status to a status of Ready To Pay. 

When creating a scheduled agent, what are her options for the schedule frequency?  

A.Hourly, Daily, Weekly, Monthly, Annually  

B.Once, Daily, Weekly, Monthly, Annually, Never  

C.On Startup, On Shutdown, Daily, Weekly, Monthly  

D.More than once a day, Daily, Weekly, Monthly, Never  

Answer:D  

16.When a user clicks a link in the left frame of the Review application, the linked data displays in the 

frame on the right. Which one of the following did Kristin do to allow this action to happen?  

A.Entered the name of the target frame in Hotspot properties  

B.Entered the name of the target frame in Frameset properties  

C.Entered the position of the target frame in Frame properties  

D.Entered the position of the target frame in Hotspot properties  

Answer:A  

17.Jonas has created a section on the Site Visit form and he would like it to be collapsed when the form is 

opened in the Notes client. How can he configure his application to accomplish this task?  

A.There is no way to do this; sections always open expanded.  

B.Modify the section property Opened for Reading to auto-hide.  

C.Change the section type from standard to controlled access.  

D.Modify the section property Opened for Reading to auto-collapse.  

Answer:D  

18.Heidi selected a document in a view and selected the menu option Edit > Copy As > Document Link. 

What did this selection do?  

A.Created a new copy of the document in the database.  

B.Copied the unique ID of the document to the Windows clipboard.  

C.Created a new document in the database that is a Response document to the selected document.  
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D.Copied reference information about the document to the Windows clipboard, that can be pasted as a 

doclink in a Notes rich text field.  

Answer:D  

19.Erica has created a Registration form for the Customer Orders application. She has set the Type 

option of the Pwd field to Password. What do users see displayed as they populate the Pwd field?  

A.An asterisk displays for each character that is typed.  

B.The encrypted value of each character is displayed as the user types.  

C.The user sees nothing displayed, but the typed characters are captured and stored as an encrypted 

value.  

D.As the user types in the Pwd field, the typed characters display. When focus leaves the field, asterisks 

display, and the typed characters are stored as an encrypted value.  

Answer:A  

20.Janet uses Domino Designer's dynamic help feature to clarify something. What kind of help does she 

get?  

A.An animated, talking icon that offers to assist her  

B.A wizard that follows a support tree to narrow down the answer to her question  

C.A personalized search interface that remembers all of her previous searches and their results  

D.A context-sensitive Help view that constantly updates a list of possible relevant topics based on what 

she's doing.  

Answer:D  

21.Luke accidentally closed the application navigator in Domino Designer and now he can't see the list of 

design elements that he's working on. How can he get it back?  

A.Close Domino Designer and reopen it.  

B.Click Window > Show Eclipse Views > Applications from the menu.  

C.Close Domino Designer and Notes, delete desktop.ndk, and reopen Notes and Designer.  

D.Close Domino Designer and Notes, delete bookmarks.nsf, and reopen Notes and Designer.  

Answer:B  

22.Barb is the lead developer for the Sales application and the Travel application. Each application 

consists of multiple databases. Within the application navigator, Barb would like to be able to list the 

databases of the Sales application together and then separate from the Sales application, to list the 

databases of the Travel application together. How can she do this task?  

A.For each application, create a subfolder under the Data folder. Move each set of databases to the 

appropriate subfolder. Drag each folder onto the application navigator.  

B.Click the Folders icon in the application navigator. Select the option to Create a new Working Set. 

Name the Working Set "Sales" and select the databases that comprise the Sales application. Perform a 

similar procedure for the Travel application.  

C.From Domino Designer select Create > Working Set. Specify "Sales" for the name. From the 

Application properties of each database of the Sales application, select "Sales" from the Working Set 

drop-down list. Perform a similar procedure for the Travel application.  

D.Edit the Application properties of each database that comprises the Sales application. On the Design 

tab, specify Sales for the Working Set option. Repeat for each database of the Sales application. Perform 

a similar procedure for the Travel application.  

Answer:B  

23.Hannah wants to change her font type on her Invoices XPage. What view in the Domino Designer 



The safer , easier way to help you pass any IT exams. 

6 / 7 

allows her to do that?  

A.Page view  

B.Themes view  

C.Events view  

D.Properties view  

Answer:D  

24.Malik needs to find all the design elements that reference a particular field in his database. How could 

he accomplish this task?  

A.Edit > Find Next  

B.Edit > Find/Replace  

C.File > Application > Analyze Design  

D.File > Application > Design Synopsis  

Answer:D  

25.Robert is adding an editable field called CountryLocation to the Member form in the Video Rental 

application. The field should show a value of USA when the document is first created. What formula would 

accomplish this behavior?  

A."USA" in the field's Default Value object  

B."USA" in the field's Input Enabled object  

C."USA" in the field's Input Validation object  

D."USA" in the field's Input Translation object  

Answer:A  

26.Ian is coding a translation formula for the Title field on the Video Rental form. Where can Ian find a list 

of the formula @Functions that are available to him from within the Designer application?  

A.Tools > Help > @Functions  

B.Right-click the Title field  

C.The Objects tab in the Programming pane  

D.The Reference tab in the Programming pane  

Answer:D  

27.Monroe needs to create an action button that changes a document from read mode to edit mode. What 

@Command should he use in this button?  

A.@Command([EditCurrent])  

B.@Command([EditDocument])  

C.@Command([SwitchMode];"Edit")  

D.@Command([ToggleMode];"Edit")  

Answer:B  

28.Burt has been asked to create a unique key to identify each rental transaction in the Video Rental 

database. What @Function can he use to create this key?  

A.@Key  

B.@Unique  

C.@UniqueKey  

D.@RandomKey  

Answer:B  

29.Danielle is updating the companyName field on all documents in a view. The field can include varying 

text, but the field always includes the text "Blue Corporation." For example, one of the documents has 
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"Blue Corporation, a wholly-owned subsidiary of GigantaCorp" as the contents of the companyName field. 

What formula can Danielle include in her agent to change the "Blue Corporation" text in each 

companyName field to now be "Green Enterprises"?  

A.FIELD companyName := @Replace( companyName; "Blue Corporation"; "Green Enterprises")  

B.FIELD companyName := @SetString(companyName; "Blue Corporation"; "Green Enterprises")  

C.FIELD companyName := @Set(@Middle(companyName; "Blue Corporation"); "Green Enterprises")  

D.FIELD companyName := @ReplaceSubstring(companyName; "Blue Corporation"; "Green 

Enterprises");  

Answer:D  

30.The @Formula statements that Gustavo is entering for validation formulas on his form are in a smaller 

font than he would prefer. How can Gustavo adjust the font that he sees while he is coding within Domino 

Designer?  

A.Right-click in the Programmer's pane to open the Programmer's Pane properties. Select the font, size, 

and color.  

B.Select File > Preferences > Domino Designer. Locate the Appearance section. Select Script > Fonts. 

Select the font, size, and color.  

C.Select Application properties from the application navigator. Select Fonts from the Script area of 

Options. Select the font, size, and color.  

D.Create a stylesheet with a class named DesignerScript, set the font attributes and import the CSS. 

Right-click the stylesheet and select Designer Default.  

Answer:A  


